Main window

For an introduction to Bayes Server see Getting started.

The Main window allows multiple Bayesian networks and Dynamic Bayesian networks to be loaded in the same environment.

Toolbar

At the top of the Main window is the ribbon Toolbar which operates in the same way as the Microsoft Office toolbars.

Hover the mouse over toolbar buttons to get descriptions and shortcut keys.

Press the Alt key to navigate the ribbon toolbar.

Network Tab

Main window network tab

  • Cut, Copy, Paste - allows fragments of a network to be copied and then pasted into the same network or another network.

  • Node - launches the New node window, to add a new standard node (discrete or continuous) or a new time series node (discrete or continuous). Also see BayesServer.TemporalType in the Bayes Server API for more information about additional types of time series node.

  • Decision - launches the New node window, to add a new Decision node. See Decision Graphs fro more information on Decision Nodes and **Decision graphs.

  • Utility - launches the New node window, to add a new Utility node. See Decision Graphs fro more information on Utility Nodes and **Decision graphs.

  • Nodes from data - creates nodes using data in a data source, such as a database or spreadsheet. See the Add nodes from data help, for more information.

  • Link - launches the New link window, to add a new link.

  • Structural learning - learns links from data in a data source, such as a database or spreadsheet. See the Structural learning help, for more information.

  • Distribution - launches the Distribution editor to manually edit the distribution(s) for a single node.

  • Parameter learning - launches the Parameter learning window, which can be used to learn the parameters of a Bayesian network or Dynamic Bayesian network from data.

  • Adapt - performs Online learning, adapting the network distributions given the current evidence.

  • Variable - launches the New variable window, to add a new variable to a node.

  • States - launches the Edit states window, to edit the states of a discrete node/variable.

  • Groups - launches the Group manager window, to edit a network's node groups.

  • Layout - click to layout the nodes in a Bayesian network or Dynamic Bayesian network. The drop down can be used to use an alternative layout algorithm.

  • Decompose - converts a Bayesian network or Dynamic Bayesian network that contains nodes with multiple variables, into its single variable node equivalent.

  • Unroll - unrolls a Dynamic Bayesian network. The number of time slices is specified in the Unroll Slice Count text box.

  • Reverse link - reverses the direction of a link between two nodes. See Arc reversal for more information.

  • Query-order states - re-orders the states of a variable, while maintaining the distributions of affected nodes. For more information see Query order states.

  • Validate - ensures that a Bayesian network or Dynamic Bayesian network is valid. This includes a check to ensure the network is a Directed Acyclic Graph (DAG), and that all distributions have been specified.

  • Tree - determines whether a Bayesian network or a Dynamic Bayesian network is a tree.

  • Parameter count - calculates the number of parameters in a Bayesian network or Dynamic Bayesian network.

  • Align left, Align right, Align top and Align bottom - aligns the left, right, top or bottom of nodes respectively. This is only available when more than one node is selected.

  • Center horizontally and Center vertically - aligns nodes such that their centers are aligned either horizontally or vertically. This is only available when more than one node is selected.

  • Distribute horizontally and Distribute vertically - moves nodes such that they are evenly distributed either horizontally or vertically. This is only available when more than one node is selected.

  • Equal width and Equal height - resizes nodes such that they have the same width or height. This is only available when more than one node is selected.

Query Tab

Main window query tab

  • Algorithm - the algorithm drop down, selects the inference algorithm to be used to compute queries.

  • Run - creates an inference engine, of the type defined in the Algorithm drop down. Unless Pause is checked, it also calculates any queries in Query explorer.

  • Pause - when checked, changes that would normally automatically trigger a re-query, do not. For example, when checked, changes to evidence do not trigger a re-query.

  • Stop - deletes the current inference engine.

  • Batch query - performs queries (predictions) on multiple cases from a data source, such as a database or spreadsheet. See the Batch query help for more information.

  • Log Likelihood - this launches the Log likelihood window, to calculate the log likelihood of any evidence.

  • Custom - launches the Custom query window, in order to execute an arbitrary query.

  • Strategy - displays the current strategy (policies) for a [Decision grap](2e1bb6c0-2ad6-4f34-acc4-e16b3178c92f

  • Most probable - turns on Most probable explanation and re-queries the network unless paused.

  • Mesh query - generates a Mesh query.

  • Cancel - click the cancel button, to cancel the calculation of a long running query.

  • Requery - re-calculates any existing queries in Query explorer.

  • Conflict - calculates the conflict measure for the current evidence. See the Conflict help for more information.

  • Edit Evidence - when a network is open, this launches the Evidence window, to allow evidence to be set on variables.

  • Reset - Clears all evidence on the current network.

  • Retract - turns on retracted evidence, and re-queries the network unless paused.

  • Comparison - determines whether to display query results compared to the same queries with difference evidence, or no evidence. For more information see Comparison query.

  • Base evidence - allows the base evidence, against which comparisons are made,

  • Marginals - calculates the distribution of the currently selected node, given the current evidence. This by-passes Query explorer.

  • Min - defines the minimum zero based time index (inclusive) to use for temporal marginal queries and plots. The associated drop down, determines whether the time is absolute or relative to the max evidence time.

  • Max - defines the maximum zero based time index (inclusive) to use for temporal marginal queries and plots. The associated drop down, determines whether the time is absolute or relative to the max evidence time.

  • Terminal time - defines the zero based time index at which any Terminal nodes are positioned. The associated drop down, determines whether the time is absolute or relative to the max evidence time. A relative value of zero, ensures that terminal nodes are positioned at the end of a time series/sequence.

  • Plot - calculates the marginals for temporal variables, between the Min and Max times, and charts the resulting values.

  • Scatter plot - calculates the marginals for pairs of continuous variables, between the Min and Max times, and charts the resulting values.

Data Tab

Main window data tab

  • Data Connections - launches the Data connection manager, which allows frequently used data sources to be managed.

  • Create tables - creates empty tables in a data source which can hold evidence for a network. See Create tables for more information.

  • Data Sampling - launches the Data sampling window to sample data from a Bayesian network or Dynamic Bayesian network.

  • Add nodes - creates nodes using data in a data source, such as a database or spreadsheet. See the Add nodes from data help, for more information.

  • Structural learning - creates links using data in a data source, such as a database or spreadsheet. See the Structural learning help, for more information.

  • Parameter learning - launches the Parameter learning window, which can be used to learn the parameters of a Bayesian network or Dynamic Bayesian network from data.

  • Cluster count - determines the appropriate number of clusters in a discrete latent variable from data. For more information see Cluster count.

  • Features - decides which variables are likely to influence a target variable of interest using data in a data source, such as a database or spreadsheet. See the Feature importance help, for more information.

  • Batch query - performs queries (predictions) on multiple cases from a data source, such as a database or spreadsheet. See the Batch query help for more information.

  • Data count - allows counting of items in a database or spreadsheet that match the current evidence. For more information see Data count.

Analysis tab

Main window analysis tab

  • Value of information - for a particular variable, determines which other variables are most likely to reduce its uncertainty.
    See Value of information for more information.

  • Auto insight - for a particular state, automatically extracts insight and allows dynamic drill down to discover finer grained insight. See Auto insight for more information.

  • Link strength - Performs Association analysis between nodes in a network.

  • Impact - Performs Impact analysis which looks at how different evidence sets affect a target.

  • Tree width - determines the properties of the tree required for exact inference, based on the current queries and evidence. See Tree Query for more information.

  • Sensitivity one way - Performs One way sensitivity analysis to determine how changes in a parameter affect a target.

  • Sensitivity two way - Performs Two way sensitivity analysis to determine how changes in two parameters affect a target.

  • Parameter tuning - Performs Parameter tuning which attempts to change the value of parameters to attain a value for a target.

  • Entropy - calculates the entropy of a discrete query or launches the advanced Entropy calculator.

  • Mutual information - Launches the advanced Mutual information calculator.

  • Kullback Leibler divergence - Launches the advanced [Kullback Leibler divergence calculator](Kullback Leibler Divergence).

View Tab

Main window view tab

  • Network Explorer - ensures Network Explorer is visible.
  • Query Explorer - ensures Query Explorer is visible.
  • Data Explorer - ensures Data Explorer is visible.
  • Start page - shows the Start page.
  • Properties - ensures the Properties window is visible.
  • About - shows the Bayes Server About Box which contains version and system information.
  • Help - launches the help system.
  • Options - shows Bayes Server Options.
  • Node toolbars - determines whether a Node toolbar is displayed on each node.
  • Reset messages - Resets all messages displayed in Message bars to their defaults.

File Tab

Main window file tab

  • New - creates a new empty network.
  • Open - opens an existing network.
  • Save - saves a network to a file.
  • Save As - saves a network to an alternative file location.
  • Save All - saves all open networks.
  • Print - prints the entire network.
  • Print preview - previews printing of the network.
  • Close Document - closes the current network or start page.
  • Exit - exits Bayes Server, first prompting to save any unsaved networks.
  • About - opens the About window containing version information.
  • Options - launches the Options window.
  • Recent items - a per user list of recent networks. Click an item to open.

Explorers

The following explorers are central to editing, entering evidence, and querying both Bayesian networks and Dynamic networks.

If an explorer is not visible, click the View tab on the ribbon toolbar, followed by the relevant explorer button.

Start page

The Start page is shown by default when Bayes Server is launched. To change this behavior, see Options.

It contains links to create a new network, open an existing network, and displays a list of recent items, which are maintained on a per user basis. A recent network can be opened by clicking the item in the list.

A recent item can be fixed to the recent item list, by clicking the Pin button, located to the left of the recent item.

Network Viewer

Each network is visualized using a network viewer.